您的位置:首页>新闻>AnySDK2.x 强制升级(8月11日)公告

AnySDK2.x 强制升级(8月11日)公告

lee 新闻

2015-07-21

AnySDK2.x版从2.0.0开始经历了2个版本的迭代,目前是2.0.2,且有大量用户自行升级到了该版本,已经趋于稳定,现团队决定于8月11日早上10点将目前所有其他版本用户强制升级到2.0.2版本,已经是该版本的用户在此次升级过程中不会受到任何影响。
推荐计划在11号前后打包的用户可以有2个方案,请提前做好准备:

1、提前手工升级到2.0.2版,下载地址:http://www.anysdk.com/downloads,并用此版本制作渠道包;
2、在8月11号之前把所有需要制作的渠道包做完并通过测试。

AnySDK所有的升级在服务端部分全部是兼容的,所以已经上线的渠道包不受任何影响,AnySDK2.x版本主要是新增了插件自助开发模块,方便用户自行开发新的SDK插件(仅限当前支持的6类),或者对当前已经支持的SDK插件进行升级,此举可大大提高了AnySDK整体的可用性。

在升级客户端的同时,游戏代码中集成的AnySDK Framework也需要升级到2.x版本中,AnySDK框架2.X更新说明:http://docs.anysdk.com/Framework2.X

插件自助开发相关文档:
1、自助开发概述:http://docs.anysdk.com/Sh-overview
2、自助开发工具使用手册:http://docs.anysdk.com/Sh-tool
3、插件自助开发——客户端概述:http://docs.anysdk.com/Plugins
3.1、Android插件开发:
3.1.1、插件自助开发——用户系统:http://docs.anysdk.com/Plugins_User
3.1.2、插件自助开发——支付系统:http://docs.anysdk.com/Plugins_IAP
3.1.3、插件自助开发——推送类插件:http://docs.anysdk.com/Plugins_Push
3.1.4、插件自助开发——分享类插件:http://docs.anysdk.com/Plugins_Share
3.1.5、插件自助开发——统计类插件:http://docs.anysdk.com/Plugins_Analytics
3.1.6、插件自助开发——广告系统:http://docs.anysdk.com/Plugins_Ads
3.2、iOS插件开发:
3.2.1、插件自助开发——用户类插件:http://docs.anysdk.com/Plugins_User_iOS
3.2.2、插件自助开发——支付类插件:http://docs.anysdk.com/Plugins_IAP_iOS
3.2.3、插件自助开发——广告类插件:http://docs.anysdk.com/Plugins_Ads_iOS
3.2.4、插件自助开发——统计类插件:http://docs.anysdk.com/Plugins_Analytics_iOS
3.2.5、插件自助开发——推送类插件:http://docs.anysdk.com/Plugins_Push_iOS
4、插件自助开发——服务端概述:http://docs.anysdk.com/Sh-server
5、自助插件自测流程:http://docs.anysdk.com/Sh-selftest
6、当前已经支持的SDK列表:http://docs.anysdk.com/Sdks